TUTORIAL: Element 3D Particle Replicator

Here is new tutorial that shows how to use Element 3D replicator options with many new tips!

Watch Tutorial on VC.

Watch in HD on youtube.

Included Tips:

  • Using position noise
  • Use 3D object as replicator shape
  • Use Layer alpha as replicator shape
  • Assign multiple objects to a single group
  • Create particles on the surface of a 3D object
  • Auto-Orientation and rotation options

UPDATED: Here is the final animation with Sound Design

107 RESPONSES TO "TUTORIAL: ELEMENT 3D PARTICLE REPLICATOR"
July 22nd, 2012 @ 12:56 am
This plug-in keeps getting better!
Semih
July 22nd, 2012 @ 12:57 am
You are amazing...
Thank you VC Team.
Shahzaib
July 22nd, 2012 @ 1:27 am
Sir, Can u please tell how to make Broken glass pieces in slow motion.
July 22nd, 2012 @ 1:28 am
I have a good size job coming up.............Yep I'm going to use this plug in for some cool Hot stuff.

thanks !!!
    Cj
    July 22nd, 2012 @ 4:17 am
    Good luck man. don't overdo it with element,it is a POWERful plug in :D
Kit
July 22nd, 2012 @ 1:33 am
Tea, Earl Grey, hot!

... What do you mean it isn't that kind of replicator?
    Mark T
    July 23rd, 2012 @ 7:00 am
    Engage!
bnkpro
July 22nd, 2012 @ 1:33 am
Thanks! This has really encouraged me to be more experimental with this plug in. The images you can get with the depth of field are unreal.
July 22nd, 2012 @ 1:58 am
Thank you VC team!!! :)
Mike
July 22nd, 2012 @ 1:59 am
Just tested some stuff: In 3dsmax you can uv map multiple objects at the same time, also using the same uv gizmo. I also tried assigning multi subobject materials, and...everything works as expected in Element. My brain is getting fried. Andrew, can you please remove some features from Element;o)
Christian Michael
July 22nd, 2012 @ 2:22 am
So I was about to go to bed when I thought I would click on the VC site... At 4am lol. THAT tut was awesome! Made my brain itch at the thought of possibilities! I might have to put a pot of coffee on and watch it again :0)
July 22nd, 2012 @ 2:36 am
Nice work! I hope in the future u'd can animate in Element.
Farshad
July 22nd, 2012 @ 2:45 am
Please tell us how to break a glass in Element 3D . thnx
    Christian Michael
    July 22nd, 2012 @ 3:33 am
    The glass model has to be pre fractured in a 3d program. Then when the model is brought back into element, it can be animated to break. Element doesn’t fracture/break models. There are 10 pre-fractured models in the Motion design pack.
    Farshad
    July 22nd, 2012 @ 4:56 am
    Thanks Christian
Steve Green
July 22nd, 2012 @ 3:45 am
Hi Andrew,

question about the shape/layer option - is there any way to fix the way it calculates the distribution of the particles, if for example you had an animated layer?

At the moment it just recalculates so it looks like you can't use an animated shape usefully.

On a related topic - it would be very useful to be able to use layers for the particle position/rotation/scale etc. parameters.

I'm guessing there isn't a way to do that currently, or it's not immediately obvious to me.

Thanks,

Steve
July 22nd, 2012 @ 4:31 am
Very beautiful!
Definitively needs a hide/show button beside group name (like the "eye" in photoshop).
It will be a bit less confusing with more than two objects.

I just hope element3D will be able to find, by itself, the textures path from the imported object.
And of course a slimy interface for the future, because, with more than three object...you know the rest :)
July 22nd, 2012 @ 4:54 am
Another nice one, Andrew! I'm saving up to buy it aws :)@
PS. Please check out my newest showreel! It wouldn't be possible without VideoCopilot!
http://vimeo.com/martineriksen/portfolio
    Caleb
    July 22nd, 2012 @ 6:56 am
    Nice Port
July 22nd, 2012 @ 6:32 am
I love this tutorial.
You help me by showing different ways to manipulate the objects.
I hope there will be many more tutorials for Element like this one.

This totally made my weekend.
Thanks.
Shuva
July 22nd, 2012 @ 7:54 am
WOW..That's excellent.Thanks the Greatest Team of the World.
David
July 22nd, 2012 @ 8:27 am
Hi Andrew,(Please Read Must)

I am David from Pakistan. I have been watching your tutorial from last 8 months and I never comment on your tutorial, But I really love to see your tutorial I always wait for your new tutorial I am a big fan of you.....you know when ever I start my practice on after effect...I can't start......because I start to watch your new tutorial....I wish I could meet you one day....I want to buy this 3D element but unfortunately I don't have enough money to buy that.... Its mean I have to wait for free download.

Love you Brother...
Please reply me on my comments
God Bless You.
    HUGO STRANGE
    July 22nd, 2012 @ 4:31 pm
    Wait ...what !!?
    what do you mean with that last sentence "David from Pakistan" ;-) ? are you asking for ban ?
me
July 22nd, 2012 @ 7:56 am
http://www.youtube.com/watch?v=iIlSvWXhRgM&feature=youtube_gdata_player
a tutorial in the style of this would be cool
Andrew Robinson
July 22nd, 2012 @ 9:03 am
Hi I'm running into a bit of a problem with the 3d object option. If I follow your example using the alarm clock as my 3d object I have no problems...my sphere turns into the shape of the clock. If I try anything else like a gun or guitar nothing happens. My particle disappears until I take it off the 3d object. I've checked all the settings and they are the same as the alarm clock that worked. Am I missing something?
    Jason
    July 22nd, 2012 @ 11:12 am
    I am having this issue as well, my particles are not being generated on the majority of models. Its not an issue of too many vertices either. I tried a variety of different objects, and ways to do this. nothing works.
    July 22nd, 2012 @ 11:31 am
    Could be a bug, we'll check it out.
    July 22nd, 2012 @ 2:39 pm
    I have the same problem. It seems to work only with the "starter pack" models for me.
    Andrew Robinson
    July 22nd, 2012 @ 3:35 pm
    Exactly Schwane...it works for me when using start pack models. All other models are not working for me.
    Dmanw71
    July 22nd, 2012 @ 4:43 pm
    It seems to work for the Icons, Primitives and Starter_Pack models. I have Windows 7, so i looked in the Documents\VideoCopilot\Models folder and looked in each of the folders I mentioned above and they contain .E3D or .OBJ files in them. The extra model packs come as an .epack file and appear not to work on my PC. When I downloaded the alternate models for each model pack, I just copied the .OBJ files into Documents\VideoCopilot\Models\My_Models folder and they worked fine with the 3D object Replicator Shape. I'm sure Andrew and company will sort it out. Thanks guys for this great plug-in.
    July 24th, 2012 @ 10:58 am
    Having the same problem, none of the 3d objects work for me
    Mandy
    July 30th, 2012 @ 5:20 am
    Dmanw71 is right re the 3D Replicator shape. All .obj files are working for me but .epak files aren't. I have downloaded the alternative 3D files and they work perfectly.
    BTW - this is a fantastic plug-in - Thanks very much guys! Loving it :)
    Tommygun999
    August 2nd, 2012 @ 5:32 pm
    Yeah, it's a bug, i guess — same thing there. Can't use 3d objects like gears, particle simply goes away.
July 22nd, 2012 @ 9:07 am
Best Element overview so far! Thanks again!
July 22nd, 2012 @ 9:27 am
You Are My Soul
Thanks VC
Adrian
July 22nd, 2012 @ 10:21 am
Hey Andrew.
Does this mean that we do not see more tutrials with any 3d programs? Now for the 3D effect you will only use Element 3d?:)

Translated with Google translator
    July 22nd, 2012 @ 11:33 am
    Not at all! We think having a good 3D background is important to using Element and doing visual effects so we will be getting into both over time.
July 22nd, 2012 @ 10:29 am
Thank you for another great Tutorial.

I just love Elements, the best plugin I bought for AE.

Thanks,
Thorsten
http://www.dreamridiculous.com
Eric
July 22nd, 2012 @ 10:59 am
Andrew,

Is it possible to provide the download link on these recent tutorials? Seems hit and miss and whether you can download. Appreciate it.

Eric
Kirk Productions
July 22nd, 2012 @ 12:16 pm
Hey! Thanks for the tutorial, amazing creative possibilities. Element has sooo much potential that it's hard to even imagine. :) Thanks again for creating this AWESOME Plugin!
Mackenzie Criswell
July 22nd, 2012 @ 12:19 pm
So here's the thing I have been working on a screenplay recently for a movie that I am planning on making. I've tried a lot of different software like adobe story, movie draft, final draft, etc. I even tried writing in word. But I was just wondering if anyone knew of some really good screenwriting software.
    Mackenzie Criswell
    July 22nd, 2012 @ 1:40 pm
    Forget it I found some really good new software. It's called fade in, for anyone who had the same problem, its normally 90 bucks but right now it''s on sale for 50.

    I do also recommend trying all of the following software
    Adobe Story (Plus/Free)
    Fade In
    Movie Draft
    Final Draft
    Microsoft Word :)
Maui
July 22nd, 2012 @ 12:34 pm
I tried to link the rotation of a layer via expression to the rotation property of element(replicator as well as particle look) but the linked layer doens't rotate with it. It just shows the red numbers (all set to 1°). I'm not sure if that's a bug or if it should work that way?
    July 22nd, 2012 @ 12:37 pm
    Be sure to pickwhip the values in order to get them to work correctly.
    Maui
    July 22nd, 2012 @ 2:30 pm
    That's what I did. I pickwhiped x,y and z rotation to it's corresponding x,y and z element value. I even tried the world transforms. It doesn't matter which one I pick it always shows 1° and doesn't rotate with the element layer. I've made a quick test and took a screenshot of it: https://dl.dropbox.com/u/3462772/Element_Rotation.png
    July 23rd, 2012 @ 11:52 am
    OK more specifically hold down ALT when you pickwhip the value and this will link the parameter correctly.
    Maui
    July 23rd, 2012 @ 2:39 pm
    Yes I had to hold down ALT all the time till I reached the Rotation value for the Link to work. If I release ALT instantly after creating the expression it doesn't work. Normally when I pickwhip a value it is not necessary for it to work. Maybe it's necessary for Element to know which Rotation value I mean because now the Expression reads something like this thisComp.layer("Element").effect("Element")(29) Nontheless now it works. Thanks Andrew
    chad
    July 27th, 2012 @ 12:28 pm
    I've run into the same thing too, and agree, holding ALT when you pickwhip is very strange to have to do, not a big deal, but I would have never figured out I had to do that without scouring the comments on this page.

    Normally I just alt click, then pickwhip. Any reason why you have to HOLD Alt?
July 22nd, 2012 @ 1:12 pm
1) I assume this would work, but when using a layer as the shape you can go in and modify the mask and Element will shift accordingly I assume?

2) Instead of doing that with particles, is it possible to do that with extrusions? I realize the extrusion system was largely built to deal with text, but I've been using it for some basic models that I didn't want to use a flat image for. Can you extrude from a mask, then modify that same mask and have the extrusion change?
    Eric
    August 22nd, 2012 @ 5:38 pm
    Unless I'm doing something wrong, Element only updates the modifications you make to TEXT in real time. As for shapes and mask, I still can't make the particules animate along. I really wish it can be done, but so far, no luck. Anyone?
Prasanna
July 22nd, 2012 @ 1:50 pm
Hi Andrew

How do I cooperate green screen footage with element 3D ? is there anyway i could bring the footage into the element engine ?

thanks
Rudy
July 22nd, 2012 @ 1:56 pm
Can you use the fog option with de camera tracker???
Tim Creed
July 22nd, 2012 @ 2:08 pm
The particle replicator tab is like Trapcode Form on steroids. Awesome stuff!
Daniel
July 22nd, 2012 @ 2:10 pm
How can I move the rotation point of my copters blades ??? its all OFF ???
    Prasanna
    July 22nd, 2012 @ 2:13 pm
    I am wondering the same thing
July 22nd, 2012 @ 2:11 pm
Can you make "Element 3D" for 32-bit systems??
    Kenzo
    January 2nd, 2013 @ 9:08 am
    Cara eu acho que não !! Se eu conseguir alguma coisa eu te falo (I am brasilian)
Erik
July 22nd, 2012 @ 2:22 pm
I love this plugin. I can see that you used the mograph module from C4D as inspiration. Since I know the module pretty good I think I can work right away with element. The fact that you see the result right away makes is so much easier to work with.

I think this will be the first AE plugin that will get its own plugins;)

Congratz!
Eric
July 22nd, 2012 @ 2:26 pm
Hey Andrew,
thanks for the tip! Now i realize what you can do with element using expressions and music!
That´s a reason to buy this killer plug-in. Cheers!
July 22nd, 2012 @ 2:51 pm
Hey Andrew, you REALLY should make a video of the workflow on how you create the exact same thing in a 3D program. If people saw how hard it is to get a similar quality render in a dedicated 3D program they would drop the 3D program on the spot and start using Element. Just saying.

By the way, can Element load bitmaps? I am going to need to buy Particular eventually, but it would be really useful for me if Element could do more-or-less what Particular does so I don't spend in both (I am really strapped on cash lately)
July 22nd, 2012 @ 3:26 pm
How are the sales for Element? My guess is that its bringing in a lot of moola :D
    HUGO STRANGE
    July 22nd, 2012 @ 4:28 pm
    ? You Hold Stock in VIDEO COPILOT ?
    POISON
    July 23rd, 2012 @ 4:21 am
    Andrew has 3 kids... give him a break :)
    And... he should be getting a billion $ for this plugin.
    July 23rd, 2012 @ 10:01 am
    moola=money*
    I bet its doing very well! :D
HUGO STRANGE
July 22nd, 2012 @ 6:00 pm
If anybody was wondering whether or not ELEMENT 3D was up to snuff...? then WONDER NO MORE !
As of today ANDREW can Relax lay-back a little ,with this last Demonstration.

Element 3D is for the creative minds... If you are interested in just copying tutorials click by click...then you will have a hell of time being creative with ELEMENT 3D "on your own" unless of course your just making TEXT with it....(which is a very,very,very powerful tool in ELEMENT 3D)

The red Element created looks clean,with great lighting etc..... Element 3d is not just for amateurs.... we will be seeing it in adds in the near future mark my words..... good stuff !
HUGO STRANGE
July 22nd, 2012 @ 6:03 pm
by the way what was the render time and resolution on this one...... :-) Wait let me guess..... Fast and full res. right !!!
July 22nd, 2012 @ 7:23 pm
Andrew, I use a custom 3d object for the element replicator shape, but is it possible for it to copy the color of the 3d replicator for the particles in it vertices?
Rv
July 22nd, 2012 @ 7:33 pm
You did an amazing work with this plug-in... Congrats!
Is there a way to use a low poly object as a proxy mesh (for the real time work) and then use a high resolution mesh for the final rendering?
July 22nd, 2012 @ 10:02 pm
This was just in time Andrew. I was about to request a tutorial on how to get particles to replicate from the vertices and this answered the questions for me. Thanks buddy, you're Awesome!
Cevic
July 23rd, 2012 @ 1:17 am
Does anyone know what GPU Andrew is using for After Effects? Seems to be pretty fast.
voltz
July 23rd, 2012 @ 1:23 am
Great! :D I think can we do a 3d globe or even creating a galaxy using element 3d. Or maybe update your "The Blue Planet in 3D" tutorial, Andrew.
AMin
July 23rd, 2012 @ 2:08 am
vrey Amazing..........................
Mr.Mijagi
July 23rd, 2012 @ 2:51 am
Chuck Norris is afraid of Element 3D :-)
POISON
July 23rd, 2012 @ 4:19 am
Hi guys @ VC.
After watching this tutorial i decided to test object replicator.

Did this simple setup. Assigned BOX in ch.1 as replicator, assigned CYLINDER in CH2 as replicator and assigned simple sphere as shape object to both ch1&2.
Then in gui i chose 3D object for emitter in both groups 1&2,
turned on animation and animated, however no change was happening.
What i saw was BOTH 3d replicator bjects were present in the scene so no transition was happening. the only possible visible difference was if the percentage of particles were different in groups.

So i was trying to figure out what is going on since the plugin alows for assigning the channels 1-5 for the replicator object.

If instead of lets say group 1 replicator i use ring the transformation between the ring and the CYLYNDER is ok.

Andrew is this normal ?

thanks.
Dan
July 23rd, 2012 @ 5:48 am
i have an AMD Turion(tm) II Dual-Core Mobile M520 2.30GHz processor
4.00GB RAM
ATI Mobility Radeon HD 4200
Please will element 3D work on this?
THANKS
    EmGi
    December 15th, 2012 @ 8:49 am
    i have a ati mobility radeon hd 4200 too but in my after effects cs5 it don't work ...
Jono
July 23rd, 2012 @ 7:08 am
Hey AK, super insane plug in, you guys must be working hard out there, I'm situated in a small fisherman's town in South Afrtica called Gansbaai, (colse to Cape Town) anyway I have learnt alot from you guys and it is much appreciated so I hope me putting this link up is okay, its basically my work but so much of what I have learnt was from you guys, I tried to make it as much my own as possible hope it comes across, I used the new Element Plug in for the opening shot, just a primitive and it took me 10 min, something which would have taken me hours otherwise, thanks for all the inspiration and AWESOME humuor :)https://vimeo.com/46220092
Shahzaib
July 23rd, 2012 @ 8:37 am
mc01 i mean how to make it in element 3d
yousef
July 23rd, 2012 @ 9:06 am
plz andrew i begg you tell me where do u get your sound effects ??
where can i buy them ??
July 23rd, 2012 @ 11:31 am
Hi Andrew,

I Just wanted to ask you about the MULTI-USER LICENSES since we are a company and we use more than 2 Computers for video editing and Post-production, so I waned to know if this product "Element 3D" does have the option for multi-licenses?

Thanks!
July 23rd, 2012 @ 11:43 am
I am having a problem with element changing my video card settings after using element and closing AE. I can't watch 1080p videos and if I jump into counterstrike after I have used element I get 24 fps and I usually get around 200-300. The only thing that fixes the issue is a full restart.

I'm running a six core phenom @ 3.3, 8gb of ram and a, GTS 450 1gb gddr5. Any help would be greatly appreciated thanks guys.
    July 23rd, 2012 @ 11:54 am
    Be sure to update your Graphics drivers from Nvidia.com This seems to be the cause of most users issues... we will look into this further. Thanks.
Daryl – Papua New Guinea
July 23rd, 2012 @ 2:37 pm
Hey Andrew, this is quite awesome, check out what they are doing with your "little" plug-in.

rendering Minecraft worlds in After Effects
using Video Copilot Element 3D and
Mineways: http://bit.ly/NrUW3D
July 23rd, 2012 @ 4:03 pm
Andrew,

You've already shown us some great things that you can do with Element 3D and I know you had a hand in developing every aspect of Element 3D, but I was wondering if there has been a feature or a combination of different objects and parameters that create something that surprised even you and made you just go "WOW!"
Cheers!
July 23rd, 2012 @ 7:16 pm
tecnical question, my model has a lot of materials, i have to texture everysingle part which is pain in the ... now the main rotor has many parts also the tail rotor, if i want to duplicate the model and select the rotors to group 2 to be able to animate them i have to group all the rotors parts togather which is something driving me mad.any tips or solution for a model that has too many materials?
onkar
July 23rd, 2012 @ 8:02 pm
wow!
Does element 3d works with AE CS5
John
July 23rd, 2012 @ 9:12 pm
Hey andrew, I was wondering, can you create and upload your own environment maps, or do you have to use the ones the plug-in comes with? Element looks great though, I’m just saving to get it. Thanks
July 24th, 2012 @ 11:47 am
When I try to use any model from the motion design package as the replicator, it just wont emit ANY particles at all. How can this be? Any other models work just fine.
Chris McNulty
July 24th, 2012 @ 10:49 pm
Mind = Blown. Amazing!
July 25th, 2012 @ 12:58 pm
What is the ram on ur machine Andrew and does the ram effect the performance inside element?
I have total of 8 .
July 28th, 2012 @ 2:37 am
Very Niec i love thit
Benjamin
July 28th, 2012 @ 4:31 am
andrew, please will element work with ATI Mobility Radeon HD 4200 with updated drivers?
    Bob
    April 17th, 2013 @ 9:39 am
    I have ATI Mobility Radeon HD 4200 too and it doesn't work with me with updated drivers ... :(
    June 13th, 2013 @ 4:22 pm
    Mine used to work then once i put Windows 8...it shows a blank/Black screen after loading any 3D model, now i dnt knw whats up, since i had even loaded Iphones and skull OBJ's
July 29th, 2012 @ 4:35 pm
Hi excellent website! Does running a blog such as this require a lot
of work? I have virtually no knowledge of coding but I had been
hoping to start my own blog in the near future. Anyways, should you have any suggestions or techniques
for new blog owners please share. I understand this is off subject however I just had to ask.

Thanks!
July 29th, 2012 @ 11:20 pm
Please !! Will anybody tell me which Software is he using??
b.
August 8th, 2012 @ 3:37 am
Hi, thanks for the great plug-in. Can I ask, how many computers may I install E3D on ?
Lambert
August 19th, 2012 @ 8:10 pm
Andrew, everytime i try to use element is says;
Element has encountered an unrecoverable error
Ethan
August 21st, 2012 @ 7:23 am
Is there a way to have a different colour for each of the different objects in the replicator, instead of just having one colour for all of them?
Jorge
August 23rd, 2012 @ 3:52 am
Andrew on the Starters objects I can't see the 34 objects it only shows around 12 please help
October 11th, 2012 @ 12:01 am
hi is it possible if you can control the position of the element? like for example for the preset of the bowling pin id like to make it in a triangular position just like in a bowling alley?
EdgarAllanPWN
November 13th, 2012 @ 5:07 pm
I have an array of 200 x 200 x 1 particles with a bit of a scatter position on the Z axis. I want to give the appearance of all of the objects bobbing slightly up and down independent of each other. Is there a way to animate Position Noise for just one axis?
Amir
March 20th, 2013 @ 5:24 am
Hej Andrew

Thanks for a great tutorial.

i'm trying to replicate your intro video with the sphere but i can't make it animate the same way that you do. can i ask you to mail me the preset so that i can see how you made it?

Amir
Stefan
July 9th, 2013 @ 9:49 am
Hey Andrew,
I'm using layer shape in the particle replicator, How could I keep objects only on the around of the shape, I don't want to keep objects inside of the shape.

Stefan
POST A COMMENT!
Before Posting
We're trying to encourage more thoughtful commenting.  Please take a moment to write a meaningful response to this post.
* Name
* Email (will not be published)
Website
* field is required