Optical Flares License server connectivity

Questions about Video Copilot products

Optical Flares License server connectivity

Postby fportac on 10/8/2019, 1:05 am

Hi VC Support,

I work for Foundry and we have a customer of our Athera platform (studio in the cloud) that needs to use your product.

I have setup the env var as specified in your documentation ( OPTICAL_FLARES_LICENSE_SERVER_IP=stunnel.internal ).

However the customer is still not able to license the plugin.

The machine is a Centos 7.

Worth noting that due to security reasons the network environment that the Nuke session runs in is restricted.
This means that we need to whitelist the license server and its ports in our network infrastructure.
We use a secure tunnel server (stunnel.internal) to forward requests to the license server.

When I run a Nuke session and open a terminal I can do:
curl -v http://stunnel.internal:47200

and get 'Empty reply from server', so the server connectivity is ok via TCP.

Just to verify, I see this request appear in the Optical Flares license server log (/var/log/vc_license_server.log) as
2019-10-02@10:23:35: INFO: processing client [0 of 1 used]
2019-10-02@10:23:35: WARN: client incorrect data

Thus the TCP connectivity works as expected. Is there something that we are missing here?
For example we are not allowing any UDP traffic. Is this a problem?

Otherwise we do not understand why this is not working and the customer is not able to use your product.

Any information would be greatly appreciated.

Thanks in advance
Posts: 1
Joined: 10/8/2019, 12:50 am
System Specs: MBookPro2015

Return to VC Product Support