Pro Shader textures do not apply to custom object

Everything Element 3D belongs here

Pro Shader textures do not apply to custom object

Postby saintme on 07/23/2012, 6:43 am

Hi,

so I ran into an issue just an hour ago and since i can't figure it out by myself, i wanted to post it here.
I made a pretty basic Object in Blender and exported it as an .obj file. Then I imported it into Element and wanted to apply a material from the Pro Shaders Collection, but it seems, as if the object only takes all the preferences set in the material, such as color and so on, but does not take on the texture.

Something interesting happened though; when I moved the material itself around and changes some of it's settings (like UV offset and UV repeat), the color on the object changed too, which leads me to the assumption that object only takes on a certain point of the texture for the whole object.

I hope you understand my English and what I am trying to say, and if anyone could help me out that would be great.

Thank you!
Last edited by saintme on 07/23/2012, 7:11 am, edited 1 time in total.
saintme
 
Posts: 22
Joined: 10/28/2011, 3:03 am
Location: Austria
Twitter: http://twitter.com/38GradFieber

Re: Pro Shader texture do not apply to custom object

Postby Mr_Me on 07/23/2012, 7:00 am

Change the texture mapping to "BOX (Preserve Aspect Ration) then set up the UV repetition till you get the result you want.
Mr_Me
 
Posts: 40
Joined: 07/19/2012, 6:59 am

Re: Pro Shader textures do not apply to custom object

Postby bobomet on 07/23/2012, 7:18 am

Go into the Scene Setup in Element, and go to the Model and Surface Mapping settings on the Object, and change the "Texture Mapping"to "Box" or "Box Preserve ...".
Attachments
UV Setting.JPG
UV Setting.JPG (26.26 KiB) Viewed 1901 times
bobomet
 
Posts: 191
Joined: 08/23/2010, 6:47 pm
Location: Virginia

Re: Pro Shader textures do not apply to custom object

Postby saintme on 07/23/2012, 7:25 am

Oh yeah, that worked great, thanks a million! =D
saintme
 
Posts: 22
Joined: 10/28/2011, 3:03 am
Location: Austria
Twitter: http://twitter.com/38GradFieber

Re: Pro Shader textures do not apply to custom object

Postby skykam on 07/26/2012, 4:20 am

When exporting the model from Blender you first have to unwrap the UV vertexes. You don't actually have to do anything with the UV map that creates, but you do have to generate it. Then export your model as an OBJ and don't forget to use triangles.

Then when importing into element you should be able to use both UV and Box mapping.
--------------------------
Pain is a dish best served hot. Really hot. And with jagged edges.
skykam
 
Posts: 28
Joined: 05/9/2011, 10:31 am


Return to Element 3D