I need a hand with texture mapping for imported object

Everything Element 3D belongs here

I need a hand with texture mapping for imported object

Postby sebasvideo on 07/14/2012, 10:20 am

If somebody could help me out with this I would really appreciate it. It may be of help to a lot of other people as well.

Please download this model and import it into E3D: http://www.scifi-meshes.com/forums/down ... file&id=44

You will see that as imported it's all white, with shadows depending on the position of the light. This has about 40 materials, and the creator included some textures in a folder. So lets start with the "SaucerBottom_Panels" material. When selecting it, you will see the texture properties, Diffuse, Specular, Reflection/Refraction, Illumination, Normal Bump, Occlusion and Environment. I don't have a knowledge of 3D design yet so I'm not so sure what the all mean, and reading the E3D help page that explains what they are didn't clarify it for me because I'm not familiar with 3D design.

But trying to play by ear for now, I started loading the textures in the different properties. Basically the creator gave three files for the saucer bottom, called Saucer_Bottom.jpg, Saucer_Bottom_Grid.jpg, and Saucer_Bottom_Spec.jpg. So I loaded the Saucer_Bottom.jpg into the Diffuse property, the Saucer_Bottom_Spec.jpg into the Specular property, and I tried loading Saucer_Bottom_Grid.jpg into the others and toggle the enable square back and forth to see how it affected the model, while also holding the mouse right button and move the light around without moving the model.

As far as I can see Saucer_Bottom.jpg is loaded in the right property. Saucer_Bottom_Spec.jpg, loaded into Specular, does nothing at all, whether I enable it or disable it, or move the light around when it's enabled. But the reason I've been >-|| for the past half hour is that I can't get the Saucer_Bottom_Grid.jpg to work the way it should, as part of the object. At one point I thought I had it in the right place when I loaded it into Occlusion, since the light was in a position that showed it integrated well with the Saucer_Bottom.jpg map, but then, when I move the light within the E3D GUI (beautiful GUI by the way) without moving the model, when I move the light upwards and the bottom goes into shadows, the grid seems to take the light influence in a different way and instead of following the same pattern of shadow as the rest of the plate, it looks like a totally different object.

So I loaded Saucer_Bottom_Grid.jpg into each of the other properties, and enabled and disabled each at one time, leaving Diffuse always on. The only two properties that will show the grid when enabled are Occlusion and Normal Bump, although the latter has to be brought down to 50% or it shows the grid with a weird effect. However, the result is the same with either of them enabled: when I move the light around, the grid seems not to be part of the ship.

So please tell me, what I am doing wrong here, and what's the proper way to do it?
sebasvideo
 
Posts: 158
Joined: 07/13/2012, 9:57 pm

Re: I need a hand with texture mapping for imported object

Postby xtimedt69 on 07/14/2012, 11:46 am

The textures should load into "Diffuse" that is how I have been doing it. However, I have downloaded a number of 3D models from TurboSquid and the model has to be done just right for all of the textures to work properly.

I purchased two iPhone 4S models and one worked and one did not, not matter what I did on the one the back was transparent.

I was unable to download you model without registering or I would take a look.
xtimedt69
 
Posts: 18
Joined: 07/14/2012, 6:22 am


Return to Element 3D