Page 1 of 1

Treat camera like a GoPro...?

PostPosted: 01/11/2019, 9:07 am
by mkunoff
Hey all,

I'm struggling trying to make this work. I created a null to animate an object in Element (a train). The path is super long and I was wanting to "attach" a camera to the front left side of the train and have it follow the train's movement. So far, I have not been able to achieve the effect I want and I believe it has to do with the behavior of the group null.

When I scrub through the timeline, I noticed that the null I'm using to animate the train isn't aligned with the group. The null itself doesn't stay positioned with the object. It's as if the null has a relative offset from the group itself and doesn't track with the group position.

Please help!

Re: Treat camera like a GoPro...?

PostPosted: 01/11/2019, 10:09 am
by star+circle
I can only think of two reasons why a group null wouldn't follow the E3D group it is animating, one is if the group null is parented to something else. The second on is if there are expressions involved. In all other cases it should follow the group exactly. If that is not the case here, you've discovered a new "method" to achieve a disconnection between the two. Can you share two screen shots with quad view where this separation becomes apparent. And one shot of you timeline that shows how the null is connected and animated. Perhaps there's a way to tell what the problem is that way, although it is somewhat unlikely. The only sure way would be to see the project itself.

Re: Treat camera like a GoPro...?

PostPosted: 01/11/2019, 11:11 am
by mkunoff
Does this help?

Screen Shot 2019-01-11 at 1.07.55 PM.png

Screen Shot 2019-01-11 at 1.08.22 PM.png

Re: Treat camera like a GoPro...?

PostPosted: 01/11/2019, 11:21 am
by mkunoff
As you can see , even though I have Camera 3 parented to the null, it's not moving the position.


Screen Shot 2019-01-11 at 1.16.47 PM.png

Screen Shot 2019-01-11 at 1.17.12 PM.png

Screen Shot 2019-01-11 at 1.17.21 PM.png

Re: Treat camera like a GoPro...?

PostPosted: 01/13/2019, 2:50 am
by star+circle
The one strange thing I see there is that your train is moving much more than your group null. It should move the same amount, if nothing else is controlling it. So something else must be affecting it in addition to the group null.

Re: Treat camera like a GoPro...?

PostPosted: 01/13/2019, 8:18 am
by mkunoff
Nope. I made a new group null and the same distance offset is happening. Starting to think it’s the OBJ I imported...

Re: Treat camera like a GoPro...?

PostPosted: 01/15/2019, 1:19 am
by star+circle
Is the scale at 100% in the World Transform settings in Element?

Can you strip down the project to just the null and a placeholder for the train and upload it?