Saber with Text Animators

Improve and Enhance Video Copilot Plugins

Saber with Text Animators

Postby pgladden1981 on 05/13/2016, 12:49 pm

Sorry if this is a duplicate post. I looked, but didn't find anything about my issue.
I'm trying to apply Saber to a solid and reference a text layer for the core.
The text layer has a couple of scale animators on different sections of the text (2 words), and I want Saber to scale along with the text.
I tried this on a previous set of text/saber layers and it worked with several scale/position animators, but the second time I tried it in the same comp it wouldn't work. I checked and all the parameters look the same.
I have 4 instances of saber in the comp using various text/logo layers and this is the first one to give me trouble.

Posts: 1
Joined: 05/13/2016, 12:31 pm
System Specs: Build: Element x64 1.6.2 (490)
OS: OS X 10.10.5
CPU: Intel(R) Xeon(R) CPU E5645 @ 2.40GHz
RAM: 16384MB
GPU Vendor: ATI Technologies Inc.
GPU: ATI Radeon HD 5770 OpenGL Engine
GPU Driver:
GPU Code: 0

Re: Saber with Text Animators

Postby vjk_vfx on 05/16/2016, 5:36 am

first make a pre-comp of that animation text, then auto-trace whole work area
u will get a roto of ur text animation, then u can apply a saber effect on that

that can give ur text a animation of saber
Posts: 15
Joined: 05/2/2016, 11:57 pm
System Specs: i3, gigabytes
8gb ram
500 hdd

Re: Saber with Text Animators

Postby badweasel on 03/2/2017, 9:25 pm

This appears to be a bug. And it's quite annoying and elusive. I have 3 text layers with animators on them. And 3 black solid's each with a saber fx pointing to a different text layer. The first two work fine and track the animator. The third one just doesn't. I tried moving the layers around, duplicating the working ones. As soon as I try to move it to the right spot it stops working. So it must be a bug of some sort.

The auto trace trick does not work. For my text animation the auto trace created all sorts of extra things that aren't part of the original animation.

I tried pre-comping both the text layer and the solid with the saber effect on it and that works to get the saber to track to the text, but messes up the composite modes. Initially, the glow goes away. But then if you hit the continuously rasterize button, that fixes the glow mode.

And don't forget the drill down into the effect's render settings and set it to Transparent instead of Black.
Posts: 5
Joined: 04/2/2015, 2:00 pm

Return to VC Plugin Support