Compatibility FAQs
Does your products work with my version of After Effects?
July 29th, 2008
All of our products are compatible with After Effects 7 professional and newer version. Some features like project files may be created in later versions of After Effects but all of the tutorials and elements can be used and recreated. Check product specifications for specific feature compatibility.

Most of our design tools work with QuickTime compatible host applications such as Final Cut Studio.
Products that work with QuickTime Host Applications:
July 29th, 2008
-Action Essentials 2: 720p & 2K
-Evolution
-Riot Gear
-Real Clouds

Short video demonstration for Apple Products:
http://www.videocopilot.net/apple.html
Other Host Applications:
July 29th, 2008
Element, Twitch, Optical Flares/Pro Presets 1 & 2, The Bullet, Video Streams, Serious Effects and Compositing, and Film Magic Pro are for Adobe After Effects only. The rest of the products may work fine with other applications such as Final Cut Pro, Vegas Pro, etc.
A good indication would be if it supports Quicktime .mov files and .wav files.

If you aren't sure if your program works with QuickTime, please check the compatibility for your software to confirm the use of *.mov files.

Please also note that Designer Sound Effects and Pro Scores requires that the application supports .wav files & mp3.
Will your products work for my version of Adobe After Effects?
July 29th, 2008
All of our products are compatible with Adobe After Effects 7 or later.

Most of our products are also compatible with Adobe After Effects 6.5 with the exceptions being:

Optical Flares and Pro Presets 1 & 2: Require Adobe After Effects CS3 or later
Twitch: Compatible with After Effects 6.5 or later on PC but requires 7.0 or later on MAC.

Element 3D: compatible with CS3 and later versions.
Are Your Products Compatible for Mac/PC?
July 29th, 2008
Yes, all of our products are universally compatible with Windows and Mac.