Compatibility
Mac & Windows Compatibility



Mac & Windows Compatibility - Our products support both Mac and Windows/PC. Our AE plug-ins have different requirements for operating systems so be sure to check our Product Compatibility page below for the requirements.
Adobe After Effects Compatibility



 All of our products support Adobe After Effects.
 
  • Sound FX/Music, Stock FX, and Training Products support AE 7 and later.
     
  • Our AE Plug-ins have different AE version requirements so please see our Product Compatibility page below for the requirements.
Product Compatibility With Other Editing Software



While our Plug-ins are only compatible with Adobe After Effects, we still have our STOCK FX and SOUND FX collections which are compatible with other editing software. See below for details: 

Final Cut Pro:

Compatible with our Sound FX & Music collections and our Stock FX products. The products below are compatible with Final Cut Pro:
 
  • MotionPulse
  • Pro Scores
  • Designer Sound Effects
  • ShockWave
  • Action Essentials 2
  • Riot Gear
  • Evolution
  • Flight Kit  **Excludes the Heat Distortion plug-in that’s bundled with it**


Sony Vegas Pro:
Compatible with our Sound FX & Music collections and our Stock FX products. The products below are compatible with Vegas Pro:
 
  • MotionPulse
  • Pro Scores
  • Designer Sound Effects
  • ShockWave
  • Action Essentials 2
  • Riot Gear
  • Evolution
  • Real Clouds
  • Flight Kit  **Excludes the Heat Distortion plug-in that’s bundled with it**


Adobe Premiere Pro:
Compatible with our Sound FX & Music collections and our Stock FX products. The products below are compatible with Premiere Pro:
 
  • MotionPulse
  • Pro Scores
  • Designer Sound Effects
  • ShockWave
  • Action Essentials 2
  • Riot Gear
  • Evolution
  • Real Clouds
  • Flight Kit  **Excludes the Heat Distortion plug-in that’s bundled with it**


 
VC Product Compatibility



PLUG-INS:


Color Vibrance:
  • Windows Vista + (Windows 7 requires Service Pack 1)
  • Mac OS X 10.7+
  • Requires Adobe After Effects CS5+
  • GPU Required
 

Element 3D:
  • Windows Vista + (Windows 7 requires Service Pack 1)
  • Mac OS X 10.7+
  • Requires Adobe After Effects CS5+
  • GPU Required - Supported GPU List   
 

Heat Distortion:
  • Windows Vista + (Windows 7 requires Service Pack 1)
  • Mac (Intel Only) - OS X 10.6.8+
  • Requires Adobe After Effects CS4+
  • GPU Not Required

 
Optical Flares After Effects:
  • Windows Vista +
  • Mac (Intel Only) - OS X 10.6+
  • Requires Adobe After Effects CS3+
  • GPU Optional supported cards can increase render performance.
  • Nvidia Geforce 7000 Series + (Excludes 7300 on Mac)
  • Nvidia Quadro FX +
  • ATI Radeon x1300 + on Windows / AMD HD Radeon x1900 + on Mac

    NOTE: Other graphics cards may be supported but speed improvements may not be as great. GPU Compatibility may vary on Mac converted Nvidia Cards, since updated drivers are not available from Nvidia.
 


Optical Flares NUKE:

  • Windows XP 64bit +

  • Mac (Intel Only) - OS X 10.6+

  • Linux - RHEL 5.4 for Intel64 or AMD64 x86-64 processor, such as Intel Pentium 4 or AMD Athlon, with SSE3 instruction set support (or newer)

  • Requires The Foundry’s NUKE Software - Version 7 & 8

  • GPU - Graphics card with at least 512 MB of video memory and driver support for OpenGL 2.0

            

Twitch:

  • Windows XP Service Pack 3+

  • Mac (Intel Only) - OS X 10.5.8+

  • Requires Adobe After Effects CS3+

  • GPU Not Required





STOCK FX:


Action Essentials 2:
  • Windows & Mac Compatible
  • Requires Video Editing Software. Supported: Adobe After Effects AE 7+, Adobe Premiere Pro, Sony Vegas Pro, Final Cut Pro, etc. The software must support the Quicktime .mov format.
 

Evolution:
  • Windows & Mac Compatible
  • Requires Video Editing Software. Supported: Adobe After Effects AE 7+, Adobe Premiere Pro, Sony Vegas Pro, Final Cut Pro, etc. The software must support the Quicktime .mov format.
  • **Important - Included Design Templates Require Adobe After Effects AE 7+**

  
Flight Kit:
  • Windows & Mac Compatible
  • Requires Video Editing Software. Supported: Adobe After Effects AE 7+, Adobe Premiere Pro, Sony Vegas Pro, Final Cut Pro, etc. The software must support the Quicktime .mov format.
  • **Important - The Heat Distortion Plug-in is included in Flight Kit - See Heat Distortion Compatibility Specs Here.**


Riot Gear:
  • Windows & Mac Compatible
  • Requires Video Editing Software. Supported: Adobe After Effects AE 7+, Adobe Premiere Pro, Sony Vegas Pro, Final Cut Pro, etc. The software must support the Quicktime .mov format.

 
ShockWave:
  • Windows & Mac Compatible
  • Requires Video Editing Software. Supported: Adobe After Effects CS4+, Adobe Premiere Pro, Sony Vegas Pro, Final Cut Pro, etc. File formats included are QuickTime PhotoJPG, H-264 & ProRes 422 HQ


Video Streams HD:
  • Windows XP Service Pack 3+
  • Mac - OS X 10.5.8+
  • Requires Adobe After Effects AE 7+ 




SOUND FX & MUSIC:
 
  • The following sound products are compatible with After Effects, Premiere Pro, Sony Vegas Pro, Final Cut Pro, Sound Forge, Cubase, Logic, Fruity Loops, Reason, and any other video editing program or sound editing program that supports .wav .mp3 files:
     
Designer Sound Effects: 
MotionPulse:

Pro Scores:





3D PRODUCTS: 
 

Fresh Food:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+
 

Element 3D:
  • Windows Vista + (Windows 7 requires Service Pack 1)
  • Mac OS X 10.7+
  • Requires Adobe After Effects CS5+
  • GPU Required - Supported GPU List
 

JetStrike:
  • Requires Element 3D Plug-in (version 1.6.2 minimum) if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+
 

Metropolitan Pack:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+


Money & Casino Pack:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+


Motion Design Pack:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+


Projectile Weapons:  
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+
 

Pro Shaders:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Supported with Cinema 4D R12+  (May also work with other 3D applications as well such as 3D Studio Max, Maya, etc. but would need to be rebuilt inside of those programs)
 

Sound & Music Pack:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+


Sports Pack:
  • Requires Element 3D Plug-in if using inside of Adobe After Effects.
  • Also supported in other 3D Programs such as Cinema 4D R12+, 3DS Max, Maya, and Blender.
  • Included Model Formats: OBJ Quads, .C4D R12+, FBX Quads, 3ds Max 2010+, and 3ds Max Vray 1.5+



OTHER PRODUCTS: 


Pro Presets 1 & 2:   
 
The Bullet:   
  • Windows & Mac compatible
  • Requires Adobe After Effects CS3+
  • Requires ONE of these 3D Software:
     
  1. Cinema 4D R 10.5 +
  2. 3Ds Max 9 SP2 +
  3. Blender 2.45 Peach +   **Blender is a FREE 3D software - https://www.blender.org/ **

***Tutorials were created in older version of After Effects so some of the effects may be different than in newer versions of Adobe After Effects. The effects can still be created in the newer versions of After Effects though***