Problem with same-named properties

Scripting for After Effects

Problem with same-named properties

Postby charlesbrepsant on 03/29/2017, 7:25 am

Hi all,

I am running into a problem trying to link the Motion Blur property of the Saber effect through this line:

effect("Saber")("Motion Blur")

But the result is not working.

I believe the problems comes from the fact that this "Motion Blur" property is repeated multiple times in the Saber effect, according to the following hierachies:

- Distortion/Glow Distortion/Motion Blur
- Distortion/Core Distortion/Motion Blur
- Render Settings/Motion Blur/Motion Blur

And so I imagine that after effects is not able to reference the correct property.

Has anyone run into this problem before? Is there a way to reference the correct property?

Also, I have the same problem when scripting the equivalent command line:

mysolid.property("Effects").property("Saber").property("Motion Blur").setValue(1)

If any one has a solution I would be very grateful.

Thanks in advance,

Charles
charlesbrepsant
 
Posts: 1
Joined: 03/29/2017, 7:16 am
System Specs: Build: Element x64 2.2.2 (2155.develop)

OS: OS X 10.11.6

CPU: Intel(R) Xeon(R) CPU E5-1680 v2 @ 3.00GHz
RAM: 24576MB

GPU Vendor: ATI Technologies Inc.
GPU: AMD Radeon HD - FirePro D700 OpenGL Engine
GPU Driver:
GPU RAM: 6144MB
GPU Code: 0

CL0: AMD Radeon HD - FirePro D700 Compute Engine (47.9%) (GL Interop)
CL1: Intel(R) Xeon(R) CPU E5-1680 v2 @ 3.00GHz (5.2%)
CL2: AMD Radeon HD - FirePro D700 Compute Engine (46.9%)

Re: Problem with same-named properties

Postby hans123 on 04/4/2017, 12:19 pm

Hello charlesbrepsant,

you need more or better informations what the developer has implemented.
So, it should be a good idea to ask Videocopilots Support directly: support@videocopilot.net
Why not?

Hans
hans123
 
Posts: 1077
Joined: 12/28/2012, 1:37 am
Location: Paris / France


Return to After Effects Expressions