E3D doesn't see external GPU

For Windows, Apple, displays, mouse pads etc.

E3D doesn't see external GPU

Postby vassi1i1983 on 06/2/2017, 12:20 pm

I'm on a MacBook Pro Mid-2012 and I'm using an external GPU setup (Akitio Thunder2, EVGA GTX980, Rosewill 650w PSU) on OS X 10.12.5.

Everything works and both AE and PPro see the eGPU. I can select OpenCL, CUDA, and Metal options for rendering.

However, when I drop Element 2.2 (latest) on a layer and open the interface, it's still reading my internal graphics card (Intel 4000, yuck).

Has anyone else using eGPU run into this, and is there a way around it?

NOTE: I'm not entertaining PC vs. Mac discussion. The MBP is what I have and it's what I'm using.
vassi1i1983
 
Posts: 8
Joined: 05/22/2009, 12:51 am

Re: E3D doesn't see external GPU

Postby JPT7505 on 06/2/2017, 6:40 pm

Element doesn't allow choosing a graphics cards unfortunately
JPT7505
 
Posts: 722
Joined: 02/9/2011, 8:17 am

Re: E3D doesn't see external GPU

Postby vassi1i1983 on 06/3/2017, 4:07 pm

It looks like E3D is reading the same thing AE is reading-- that my internal GPU is the OpenGL render engine.

There's actually a text file inside AE that allows you to add the names of GPUs that don't support OpenGL, so I added my internal one to the list. Unfortunately AE still sees it, so E3D still sees it.

I'm investigating further, however this doesn't seem to be an Element issue.
vassi1i1983
 
Posts: 8
Joined: 05/22/2009, 12:51 am

Re: E3D doesn't see external GPU

Postby vassi1i1983 on 06/3/2017, 11:35 pm

I was able to solve my problem by going to Library>Extensions and removing AppleIntelHD4000GraphicsGLDriver.bundle.

AE and E3D now both see my external nVidia card as the openGL render engine.
vassi1i1983
 
Posts: 8
Joined: 05/22/2009, 12:51 am


Return to Computer Hardware & Technology