Youtube video choppy during camera movement for some viewers

Premiere, Vegas, Final Cut, QuickTime, DVD authoring etc.

Youtube video choppy during camera movement for some viewers

Postby Dreamtime Visions on 04/8/2014, 10:52 pm

I am having a very confusing and frustrating issue with getting videos to play back on Youtube without camera movement being choppy.

Example: https://www.youtube.com/watch?v=ll0FxgP ... e=youtu.be

The videos play smoothly on Premiere CS5, smoothly with only the occasional stutter on long track shots on WMV and VLC when compressed and streamed on Vimeo. However, on Youtube camera movement is very choppy on my computer. I have asked various people to watch the video both in Australia and overseas, with some finding it choppy like me and others saying it is smooth.

What could possibly be causing this? Is it something I'm doing wrong in my settings, if so what? Is this an issue with Adobe flash interacting with computers/Internet/video card? If so, can I change something in my settings to stop the issue? I've tried so many tests, with no success.

Video and test details below:

Original footage: Recorded from a video game with graphics settings on high as individual jpeg images at 120 fps, 1280x720, sound clips mostly 44100 with some higher/lower.

Original footage converted into uncompressed video with Lagarith codec on Virtualdub.

Premiere sequence settings: 59.94 fps, 1280x720, square pixels, progressive, 48000hz, stereo

I then have two copies that I encode using x264/AAC. One is a downloadable version at 59.94 fps, the other is downscaled to 29.97 fps for Youtube/Vimeo.

GENERAL X264 RENDERING SETTINGS:

Avisynth:

AVISource("J:\Final Youtube Tests\Test 7\Test 7.avi", audio=false).AssumeFPS (30000,1001)
#deinterlace
#crop
#resize
#denoise
ConvertToYV12(matrix="rec601")

X264 Megui settings:

http://imgur.com/Mg7vSV5
http://imgur.com/YrERgbM
http://imgur.com/ZpzH5qb
http://imgur.com/iEA0Lzg
http://imgur.com/BehBhVj

TESTS:

Rendered in the following formats, but all have provided same choppy Youtube playback:

x264/AAC mp4 through Premiere CS5
WMV through Premiere CS5
Uncompressed render from Premiere CS5 and x264/AAC through Avisynth/Megui

Experimented with many different settings, but all have provided same choppy Youtube playback:

Rendering new footage out at 30 fps instead of 120/sequence settings/export all at 30 fps
Putting a 59.94 fps version on Youtube instead of downscaling to 29.97 fps
x264 levels (3.2 and 4.1)
300 max keyframe interval, 30 minimum keyframe interval GOP settings
0 vbv buffsize and 0 vbv maxrate
78125 vbv bufsize and 62500 vbv maxrate

You can see my most recent tests on my Youtube channel (encoder details in 'About' section of most of the vids):

https://www.youtube.com/channel/UCfcDkR ... -ErMcSCbTg

Very frustrated and no clue how to fix this issue. I can provide more details if needed.
Dreamtime Visions
 
Posts: 1
Joined: 04/8/2014, 10:42 pm

Re: Youtube video choppy during camera movement for some viewers

Postby JonZ on 04/15/2014, 1:19 pm

I have the same problem as well. I look on every forums and non has any answers. I think I tried with IE (unfortunately) and videos played smoothly, so I think it between how Flash and the browser. People thought of turning off HTML5 or turning it on but It not fixing the root problem for my viewers.
JonZ
 
Posts: 59
Joined: 10/8/2011, 8:50 am


Return to Video Editing, Authoring & Compression